DocShuttle Dictator

From Bytescribe Support
Jump to: navigation, search

The DocShuttle Dictator module is designed for use by a single dictating physician. DocShuttle Dictator has many of the features of DocShuttle Administrator, but is limited to viewing files for one particular job type or user ID. The DocShuttle Dictator module allows automatic importing of voice files from handheld recorders, automatic uploading of voice files to an FTP site, and automatic downloading of completed text documents from the FTP site. The status of every job is displayed for the user of the system. The status of each job is shown as either new, downloaded by transcriptionist, completed by transcriptionist, or completed with attached document. All files can automatically be securely encrypted with 256 bit encryption. Completed text documents are downloaded as they are completed by transcriptionists


Dsd1 DocShuttle Dictator.png



The DocShuttle Dictator window has two panes. The top pane displays files on the FTP server. The bottom pane displays files on the local computer hard drive. Files can be uploaded to the FTP server either by dragging files from the bottom pane to the top pane or by clicking the arrows in the button bar at the top of the window.

CONFIGURING CONNECTION INFORMATION

Setting Up DocShuttle Dictator Click Tools | Settings from the DocShuttle Dictator window to configure the settings. The host address, username and password must be entered. Also enter the job type you will be using in the "User's Job Type" field.


Dsd2 Menu Tools Settings.png


Connecting to a FTP Site

Once the settings have been entered, simply press the 'Connect' button on DocShuttle Dictator to connect to the FTP site. Once connected, all files in the "User's Job Type" folder on the FTP server will be displayed in the DocShuttle Dictator window.


Dsd3 Menu Connection.png


SETTINGS

Click on the Tools menu and select Settings. There are four main tabs in the Settings window as shown below. These tabs are FTP, Local, Import, and Advanced. We will go through each in more detail below.


Dsd4 Settings.png


FTP SETTINGS

The FTP tab, in addition to containing the connection settings (host address, username, password, etc), allows users to encrypt files on the FTP server, choose which files to display, and control timezone settings (if other than Eastern Standard Time) as shown below.


Dsd5 Settings FTP.png


Timezone Settings

Server timezone offset (default is 0). If user is working from a timezone different from the FTP server (e.g. EST), this setting will correct the time for files on the server. For example, if it is 11:00am EST (Eastern Standard Time) but the user is working at 8:00am PST (Pacific Standard Time), the timezone offset setting would be set to -3 (3 hours less than the default setting of 0).


Dsd6 Settings FTP TimeZone.png


LOCAL SETTINGS

The Local tab within the Settings window allows users to modify "size per minute" settings for multiple audio file types. Other preset criteria for FTP and local files can be customized per the user's preference.


Dsd7 Settings Local.png


Scheduled Processes

As shown above, users can control how often (timer interval in minutes) certain functions take place. These scheduled processes include uploads, downloads, deleting local & FTP files, importing of files, and refresh of data.

IMPORT SETTINGS

Importing Voice Files from Handheld Recorders

Voice files may be imported from digital handheld recorders or other systems that create sound files. DocShuttle will import files that have *.wav, *.vox, *.dss, *.mp3, *.msv, and *.dvf extensions. Other sound file extensions can also be specified in the settings. There are two methods for importing voice files. One method is to specify the import directory where files may be found in the Settings window. Select Tools | Settings from the DocShuttle Dictator menu and click the Import Tab. The window shown below will appear. Specify the import directory, user ID and job type for each folder. Importing may also be scheduled by selecting the "Local" tab in the Settings window. Once the settings have been entered, you may import files by selecting the Tools | Import Files menu option from the DocShuttle menu.


Dsd8 Settings Import.png


Another method for importing files is to drag-and-drop sound files directly from Windows Explorer into the DocShuttle Dictator window. This method will import files into the default job type folder using the default user ID (the first line shown in the image above). DocShuttle will import files that have *.wav, *.vox, *.dss, *.mp3, *.msv, and *.dvf extensions or extensions specified on the Local tab.

ADVANCED SETTINGS

Viewing a Range of Folders

When connecting to an FTP site, DocShuttle Administrator will display files in all folders specified. If using a slow Internet connection or if a very large number of files exist on the server, the loading time may be significant. If you wish to view a range of folders, you may specify the range of folders to view. Select Tools | Settings from the DocShuttle menu and click the Advanced tab. Then specify the range of Job Types you wish to view.


Dsd9 Settings Advanced.png


Transferring Files using DocShuttle Dictator

All new files can be uploaded by pressing the "Upload New Files" button or from the "File Transfer" menu (see below).


Dsd10 Menu File Transfer.png


Many functions such as running reports and moving files can be performed by right-mouse-clicking within the panes of the DocShuttle Dictator window (see below).


Dsd11 Right Click Menu.png


Importing Voice Files from Handheld Recorders

Voice files may be imported from digital handheld recorders or other systems that create sound files. DocShuttle will import files that have *.wav, *.vox, *.dss, *.mp3, *.msv, and *.dvf extensions. Other sound file extensions can also be specified in the settings on the Local tab. There are two methods for importing voice files. One method is to specify the import directory where files may be found in the Settings window. Select Tools | Settings from the DocShuttle Dictator menu and click the Import Tab. The window shown below will appear. Specify the import directory and user ID for each folder. Importing may also be scheduled by selecting the "Local" tab in the Settings window. Once the settings have been entered, you may import files by selecting the Tools | Import Files menu option from the DocShuttle menu.


Dsd12 Tools Settings Local.png


Another method for importing files is to drag-and-drop sound files directly from Windows Explorer into the DocShuttle Administrator window. This method will import files into the default job type folder using the default user ID (the first line shown in the image above). DocShuttle will import files that have *.wav, *.vox, *.dss, *.mp3, *.msv, and *.dvf extensions or extensions specified on the Local tab.

Managing Files using DocShuttle Dictator

File management using DocShuttle Dictator is easy because the status of all files is shown in the program window. Local files (shown in the lower pane) can have the following status: "New", "Stat", or "Transferred". Files that have not been uploaded have either "New" or "Stat" status. Once they have been uploaded to the FTP site, they will have the "Transferred" status.

FTP Files (shown in the upper pane) can be the following status: "New", "Downloaded", "Completed", or "Uploaded". Each status is shown with a unique icon. When files are first uploaded, they will all have a "New" status. When a transcriptionist downloads a file, the status will turn to "Downloaded" and the file will appear with a yellow lightning bolt icon. When the transcriptionist completes the file, the status will turn to "Completed" and the file will appear with a red flag icon. If the transcriptionist attaches a text document and uploads the document, the status will turn to "Uploaded" and the file will appear with a red paperclip icon. When all files in the upper pane of the DocShuttle Dictator window are marked with a red icon, this indicates that all files have been completed by the transcriptionists.

Below is a chart that shows the different statuses that a file can have. There are two columns of icons. The right column of icons indicates the status of the voice file. The left column indicates the status of the attached text document. If a voice file has been completed by a transcriptionist, it will be marked with a red flag. Files that have a colored paperclip icon represent files that are being reviewed for quality assurance purposes. The "Uploaded" status represents a file that is fully complete. Files with this status have a red flag and black paperclip beside them.


Dsd13 legend.jpg


Managing Text Documents

DocShuttle Dictator can download text documents for all files that have been completed by the transcriptionists. To view all completed text documents, select Tools | Document Manager from the DocShuttle Administrator menu (see below).


Dsd14 Menu Tools Document Manager.png


The Document Manager window shown below will appear. The Document Manager displays all downloaded text documents. This window enables functions such as printing, viewing, searching and creating reports. A scheduling feature allows automatic printing of all newly downloaded documents.


Dsd15 Menu Tools Document Manager Window.png


Creating Reports

Reports may be easily created using the Document Manager window. Simply select File | Custom Report from the Document Manager menu.


Dsd16 File Custom Report.png


After clicking "Custom Report" the dialog box shown below will appear.


Dsd17 File Custom Report Window.png


To create a report, select the criteria from the dialog box and click the Create button. If the documents downloaded by DocShuttle are Microsoft Word documents and Microsoft Word is installed on the computer, you may select the "Include MS Word Statistics" checkbox to include line count information in the report.

Purging and Deleting Files

Files that have been marked as "Completed" or "Uploaded" on the local hard drive may be purged using the "Purge Files" button. In the Settings window, you may specify how old files must be before they are purged. This function works by deleting each file that meets the criteria specified. The user may also manually delete files from the local drive by right-clicking on selected files and choosing the "Delete" option from the popup menu that appears.

LAYOUT OF DOCSHUTTLE DICTATOR

Window Panes As shown above, the DocShuttle Transcriptionist window has two panes. The top pane displays files on the FTP server. The bottom pane displays files on the local computer hard drive. Files can be uploaded to the FTP server either by dragging files from the bottom pane to the top pane or by clicking the arrows in the button bar at the top of the window.

Menu Bars

Dsd18 Toolbars Menu Bar.png


The menu bar (shown above) in DocShuttle Transcriptionist contains 5 main menus: File, Connection, File Transfer, Tools, and Help. Each sub-menu command will contain a shortcut icon, description of the command, and keyboard shortcuts.

The shortcut bar (shown below) allows the user quick access to some of the most common commands. These icons are also shown on the left side of the corresponding command from within the sub-menu of the menu bar. For example, the icon for the "Find" command is an image of binoculars.


Dsd19 Toolbars Shortcut Bar.png


If you hold the curser over a shortcut icon, the menu name will appear in a light yellow box as shown below.


Dsd20 Toolbars Shortcut Bar Icon Name.png


Keyboard shortcuts are listed to the right of each command. For example, to "find" text within the DocShuttle window simply press the CTRL key and F key at the same time. This shortcut is shown as Ctrl+F.

1. The File menu allows you to record and play sound files, view documents, check file properties, find text, run reports, and create message files as shown below.


Dsd21 Menu File.png


2. The Connection menu allows you to connect or disconnect from the FTP server. The shortcut icon is also shown.


Dsd22 Menu Connection Connect from FTP.png Dsd23 Menu Connection Disconnect from FTP.png


3. The File Transfer menu allows the user to Upload new selected files from the local files (lower window) or Download new or selected files from the FTP server files (upper window).


Dsd24 Menu File Transfer.png


4. The Tools menu contains commands for Document Manager, Status Summary, View/Clear Logs, Purge Local Files, Import Files, and Settings.


Dsd25 Menu Tools.png


5. The Help menu contains content documentation, tips to improve user functionality, ability to check for software updates (if available), and information about the current software version of DocShuttle.


Dsd26 Menu Help.png